Simple box collision uses too many particles

Posted by:thanulee
Data created:20 May 2016

Hi, i just add a box and a plane. Plane as collision, box as rigid body. My fps drops to like 6 in a 980ti card and the box has way too many particles. What am i doing wrong? thanks

Attached Files:

>lucid+issue.JPG (105691 bytes),

You need to adjust your resolution and/or particle radius parameters, read here:

Marsel Khadiyev (Software Developer, EPHERE Inc.)

This is the default behavior btw as i made a single box, i didnt change anything.If i have bigger particles, the simulation goes completely wrong. And if i have smaller it becomes way heavier. How can i change the number of particles? I can only affect their size with those 2 parameters. Thanks

And if i understood correctly particle radius is the same as resolution. I just overwrite the one value with the other. What is the proper way to do this? I usually play with resolution alone to get what i need and i ignore the radius. I never tried a simple object as a box in the past, i was only trying clothes and all was fine, but with this box is like its adding so many particles to a flat surface.

Particle radius sets the size manually and resolution will try to fill the volume with particle count you specify. Generally it is better to enter the size manually. Generated particles within a volume will be placed next to one another, so bigger resolution will make them smaller.

Marsel Khadiyev (Software Developer, EPHERE Inc.)

"Particle radius sets the size manually and resolution will try to fill the volume with particle count you specify. "
How do i specify particle count? U mean when i have resolution at 30, i have 30 particles? Cause i ve seen this is not the case and that radius and resolution behave exactly the same, and I can use either the one or the other but not both. I have no control over the number of particles to be generated on a flat surface. I can only have big or small the X number auto generated by lucid.

So in case of just some boxes falling down, if i have big particles (aka small resolution), boxes collide with each other in the air. If i have small particles, scene is way too heavy for just a few boxes. Whats the workaround on that?

Did you read the documentation about the particle size and resolution (I posted the link in my first reply)? Particle size in Lucid is global so all objects will have particles of the same size. Resolution doesn't mean that you will get that many particles. It is merely a rough way of automatically increasing or decreasing particle size based on the scale of objects inside your scene.

If you specify particle size manually (give it a non-zero value) it will override the resolution parameter. Your particles need to be sufficiently big to ensure you have a fast and stable simulation. It will require tweaking.

Marsel Khadiyev (Software Developer, EPHERE Inc.)

Ya i did but practically i see no difference between the 2 ways. I get exactly the same amount of particles and exactly the same size either with resolution or size. There is no difference how i set it up. I think i had to tweak hard the shape distance to avoid objects colliding in the air. I ll come back with a scene file and some screenshots. thanks

Ok, thank you. The distance parameter is important for stability. However increasing the particle size should have significant effect on the scene.

Marsel Khadiyev (Software Developer, EPHERE Inc.)