Leaking fluid, no matter what I do. Can this be fixed? Time critical, please help!

 
 
 
Posted by:eddaly
Data created:14 December 2016

No matter what I do, I can;t get this mesh to stop leaking. I've tried adjusting Particle Radius, Solid Rest, Dist To shape, Sub Steps... I've spent the best part of three hours on this. Not good, as this is a time critical project... 

Can someone at Esphere please respond and let me know if this is even solvable with Lucid - I'm a bit disappointed so far. I wasn't expecting Real Flow, but this should work shouldn;t it?!


Attached Files:

>lusidLeak.max (4534272 bytes), >lusid_leak.JPG (118147 bytes),

Hi Eddaly,

We are going to take a look at this issue and report back to you ASAP.

 

Best Regards,

Jeordanis Figuereo

Jeordanis Figuereo (Product Designer. EPHERE Inc.)

Guys, this is awful. I can;t even get liquid to stop leaking through a stretched sphere - this is a simple concave mesh. I've attached another file and screenshot. 

Also worth noting, the collision seems to be slightly better in 2016, I tried to recreate your demo (below) in max 2017 and it wouldn't work at all, though did work in 2016.

https://www.youtube.com/watch?v=GatAbToQQ4c

Can you please tell me what settings I should be using to avoid this leaking


Attached Files:

>lusidLeak2.max (167936 bytes),

Sorry, here's the 2nd screenshot


Attached Files:

>LucidLeak2.JPG (134244 bytes),

Hello,

The particle tunneling is likely due to the thin walls of the container. Have you tried adding a shell modifier and giving the sphere some thickness?

Marsel Khadiyev (Software Developer, EPHERE Inc.)

Yes, I've tried that. I've also trid segmenting the geometry and rebuilding it several times. 

How come your demo (below) works with thin wall/single face geometry? I can't even recreate this in max 2017 without leaking. 

https://www.youtube.com/watch?v=GatAbToQQ4c 

Can you please look at my first file, and make a suggestion on how to make this work? Or confirm that Lucid can't do this kind of thing

In your original scene set the body type of HeadOutline_master to SDF and increase the Resolution in the SDF settings to 200.

Looks like the specific topology of the collider causes problems (the long creases at the sides). We'll look into improving collision detection with standard colliders in this case.

In general, dynamic simulations prefer regular meshes. The ability of the SDF object to increase the resolution allows working around problems with more complex collision geometry.

Ivan Kolev (Software Developer, EPHERE Inc.)

"In general, dynamic simulations prefer regular meshes"

By regular I mean not just correct topology (no self intersections, wings, etc.), but also faces of similar size and vertices with similar number of outgoing edges. For example, it is much better to use Geospheres rather than standard Spheres in dynamic simulations. The poles of the standard sphere (and similar primitives like the capsule of your second example scene) are rather simulation-unfriendly.

Ivan Kolev (Software Developer, EPHERE Inc.)