Help: preserving hair grooms between version updates

 
 
 
Posted by:gsanjuan222468
Data created:23 July

 

Hello everyone,

I tried to find more about this in the forums before posting but couldnt find anything concrete-  I notice that when I create hair grooms, and then update to the latest version of ornatrix for Maya, I open up those previous grooms and there are guides that are how I styled them, but a whole set of grooms that are sticking straight out.  

My question is is there a way to preserve my original hair groom before the update? Are there tools within the guides operator menu to help me retain all my previous work done with older versions of Ornatrix?

Any help with this would be greatly appreciated!

Thank you, 

Glenn


Attached Files:
Image 1

Hello,

This is not expected. Do you remember the exact build where you created the groom? What build are you using right now? 

Jeordanis Figuereo (Social Media Manager, Product Designer. EPHERE Inc.)

Yes, the original hair grooms in our system were created with this build:  2.3.8.19783 (11 June).

They have worked in our renderfarm on that build.  When I updated to recent builds and opened the older files created from this build, half of the guides appear straight out and not affected by any of the guide operators.  Please let me know if you need any more information.  I am running Maya 2018 and have been since last year.

Thank you,

Glenn

And the guides are broken in 2.4.0.20213?

Jeordanis Figuereo (Social Media Manager, Product Designer. EPHERE Inc.)

I cannot reproduce this issue. I tried creating a groom in 2.3.8.19783, planted some guides and comb them. Then installed the latest stable and the scene loads fine. Can you share the problematic scene for testing (only the hair)?

Jeordanis Figuereo (Social Media Manager, Product Designer. EPHERE Inc.)

Hello Jeordanis,

Attached is one of our hair grooms tied to a skull cap with a transparent material on it.  When you click on the "edit guides" stack operator, you will see guides that conform to the hair style, there are others that remain straight out in space.  I can still manipulate them, but I have been told by my co-worker that all of our previous grooms behave this way when created on a build previous to the latest v2.4.0.  

 

Thank you for all your help!

Glenn


Attached Files:

>broken_guides_01.ma (2628490 bytes),

Thank you, we are looking into it. 

Jeordanis Figuereo (Social Media Manager, Product Designer. EPHERE Inc.)

Are you sure it was working fine on 2.3.8.19783? Maybe it was an older version? What OS are you using? Can you please save the scene as .ma?

Jeordanis Figuereo (Social Media Manager, Product Designer. EPHERE Inc.)

The file I sent you is a .ma.  I am currently running Windows 10 Pro build 17763.615.  

I say build 2.3.8.19783 because that is the first build that we started using Ornatrix to create hair for our project.  I have delayed upgrading as this has happened with previous builds, I couldnt resist this last upgrade as the production tools are so much better.  The only problem now is that our previous hair grooms now show these characteristics of guides sticking striaght out.

I can attempt to send you more files if you like?  Please let me know.  Thank you.


Attached Files:

>broken_guides_01.ma (2628490 bytes),

Sorry, I meant a .mb file but it's OK. The scene you just sent is crashing for one of our devs, please send another if you can. 

To clarify, the hair should not change between different builds, this is definitely a bug.

Jeordanis Figuereo (Social Media Manager, Product Designer. EPHERE Inc.)

Thank you Jeordanis-  Here is another one of the most recent grooms I have created - saved both .ma and .mb for you to look at.  This groom was created last month and the version I updated to was 2.3.8.19783.  I opened this one today and it appeared the same.  When edit guides is turned on, the adjusted guides show, but are surrounded by guides that are extended/unaffected.  

 

If you have any other questions, I will be leaving this thread open to help you out.

Thank you,

Glenn


Attached Files:

>mh_hair_head_med_morten_j_01.ma (2647500 bytes), >mh_hair_head_med_morten_j_01.mb (1750168 bytes),

Jeordanis, I have done some troubleshooting on my side and found a couple of things that might help:

 

- The bug does not happen to all grooms, but most of them that have been physically combed downward and not been procedurally brought downward by gravity or surface combing are affected.

- The bug seems to add guides over the hair groom - when I delete the ones sticking out using edit guides, the hair style is still underneath.

Would you happen to know why unstyled guides would be added to a scene?  I will keep trying to debug...

 

 

This seems to be the same problem as reported in https://ephere.com/plugins/autodesk/maya/ornatrix/forums/general/thread_12823.html

Is that correct?

In all of the example scenes of that thread and this one:

ornatrix_scene_problem.ma
broken_guides_01.ma
mh_hair_head_med_morten_j_01.ma
mh_hair_head_med_morten_j_01.mb

the stack is broken beyond repair, the operators are not connected to each other properly, the top HairShape is connected directly to the GuidesFromMesh node instead of the node that is at the top of the stack.

I don't know how has this happened, I don't think it can happen easily by "normal" use, and definitely not just by loading an older scene into a newer version of the plugin.
Yes, we have scripts that take care to maintain the connections and it is possible that they have messed up something, but not in a simple way. And we have a good amount of automated tests of those scripts.

So we need exact steps to reproduce the problem, maybe with an example scene (preferred format is zipped .ma) that was saved in an older version of Ornatrix and that is broken when loaded into the latest stable (but loads fine in the same version it was saved with). Of the scenes provided so far only the first one, ornatrix_scene_problem.ma, was saved with a previous version (2.3.8), but it is broken even when loaded with that same version, so maybe it was already broken when saved.

Ivan Kolev (Software Developer, EPHERE Inc.)

Thank you Jeordanis and Ivan for your help,  I have gone through about 95 hair grooms that I have created and maybe 1/3rd of them have this error that appears.  I believe through Maya we are seeing a lot of history attached from previous stack operators no longer there or not activated.  

Are there any cleaning procedures during the working process of adding operators that needs to be done in order to keep a hair groom "clean" and free from strange errors?

 

Hm... Have you deleted the history of the distribution mesh at some point? 

Jeordanis Figuereo (Social Media Manager, Product Designer. EPHERE Inc.)

Hi,

Not to jump in, but this is the same issue I emailed you about earlier this week Jeordanis. When we went from 2.3.7.19651 to the 2.4 latest build, all the grooms exploded and I had many, many 'non-existing guide dependency error's. 
And this happened to every groom we checked, but the other issue with the dependency errors and crashing we had to revert back.

And the latest build was still missing 'mass per vertex' though I am not sure if that is important. Just concerned it was in the Moov demo so it appeared that way.

I am trying to talk them into sharing a scene, but the client is very strict so far.

Thanks,
Dax

I will let you know when the Mass Per-Vertex is added. 

This issue is complex because is not something we can reproduce easily , not even jumping from one version to another. 

Jeordanis Figuereo (Social Media Manager, Product Designer. EPHERE Inc.)

Oh I totally get it. I've used all kinds of hair solvers at all kinds of shops, it's not easy :)

Thanks Jeordanis! I am going to ask again if we can't just send a scene.

 

d3d,

Let's try something. Go back to the version where the hair was fine, save the groom as a preset, install the new version and load the hair preset in a new scene. Please try this and tell me the results. 

Jeordanis Figuereo (Social Media Manager, Product Designer. EPHERE Inc.)

Apologies Jeordanis, I did not see a notification of a reply.

Thank you for the suggestion! Will try it as soon as possible.

Dax